在wampserver环境下配置多个版本的PHP支持

 WAMPServer可以让开发者在Windows系统下快速搭建WAMP环境,它支持多版本的Apache、MySQL、PHP之间的相互切换,互不影响,对于PHPer开发者来讲极为方便快速。最近有个需求,需要用到PHP5.3,可是在wampserver3中默认安装的没有PHP5.3版本,参考了网上诸多大佬的配置方案,仍然未成功(ps:是自己太笨了.....)。最后折腾了一晚上才发现官网早就为我等小白准备好了 废话不多少,放干货:

1:首先安装wampserver

  这个就不用多少了吧,官网下载对应的32或者64的安装包,然后一路next。(ps:如果你以前安装过wampserver或者一些MySQL,那么可能在安装wampserver的过程中会出现一些小小的问题,不过自己清理一下注册表,在重新安装就会ok了)

2:登录WAMPServer官网

点击SourceForge

技术分享图片

在下图中点击自己版本对应的文件件,比如我安装的是wampserver3版本

技术分享图片

 

技术分享图片

 

技术分享图片

 

技术分享图片

 

然后直接按Ctrl+F 在网页上搜索你想要安装的PHP版本,然后下载一个.exe的可执行文件

3:安装上一步下载的.exe可执行文件,他会自动搜索你在第一步安装wampserver的安装目录,并且把对应版本的PHP安装到bin/php目录下。

然后就大功告成了(ps:完成之后不要点击restart,直接exit退出,然后重新进)

 

在wampserver环境下配置多个版本的PHP支持

原文:https://www.cnblogs.com/Triw/p/9251785.html

人吐槽 人点赞

猜你喜欢

发表评论

用户名: 密码:
验证码: 匿名发表

你可以使用这些语言

查看评论:在wampserver环境下配置多个版本的PHP支持