centos安装phpUnit

首先需要确认你的php版本,以及该版本对应的phpunit的版本

主版本初始版本PHP兼容性支持
PHPUnit 82019年2月1日PHP 7.2, PHP 7.3, PHP 7.4在2021年2月5日结束支持
PHPUnit 72018年2月2日PHP 7.1, PHP 7.2, PHP 7.3在2020年2月7日结束支持
PHPUnit 62017年2月3日PHP 7.0, PHP 7.1, PHP 7.2在2019年2月1日结束支持
PHPUnit 52015年10月2日PHP 5.6, PHP 7.0, PHP 7.1在2018年2月2日结束支持
PHPUnit 42014年3月7日PHP 5.3, PHP 5.4, PHP 5.5, PHP 5.6在2017年2月3日结束支持

安装phpUnit的phar档案包

安装完成后可以通过命令行phpunit 来操作phpunit相关命令测试

在网址https://phar.phpunit.de/ 查看你版本对应的phpunit的路径名称 

比如我php版本是5.6, 我能使用的phpUnit版本是phpUnit5, 在上面的网址中我找到的最新的phpUnit5的版本是phpunit-5.7.9.phar 这个就是我本次要下载的phpUnit

wget https://phar.phpunit.de/phpunit-5.7.9.phar    //下载phpUnit

chmod +x phpunit-5.7.9.phar    //更改文件的可执行权限

sudo mv phpunit-5.7.9.phar /usr/local/bin/phpunit   //增加命令行功能

测试phpUnit是否安装ok

phpunit --version (或者phpunit --help)

安装项目的phpunit依赖 使用composer

https://packagist.org/explore/ packagelist网站 输入phpunit 查询phpunit的所有composer库

使用composer引入phpunit并将phpunit放入项目的vendor中

通过上面的网址查看phpunit的库中都有什么版本 使用composer安装phpunit

composer require --dev phpunit/phpunit ^5

至此 phpunit安装完成

文章来源: centos安装phpUnit

人吐槽 人点赞

猜你喜欢

发表评论

用户名: 密码:
验证码: 匿名发表

你可以使用这些语言

查看评论:centos安装phpUnit