centos7安装php5.6报错集合

安装PHP时显示,xml2-config not found
这里需要安装的是libxml2-dev软件包(该软件为Ubuntu-Server自带的,需要使用Ubuntu-Server光盘安装),操作如下:
sudo apt-get install
libxml2-dev
库文件安装完成后,重新配置PHP
编译完成后将会看到“Thank you for using PHP.”的字样,表明PHP已经配置成功了。

错误1:Cannot find OpenSSL‘s <evp.h>

解决:yum install openssl openssl-devel

ln -s /usr/lib64/libssl.so /usr/lib/

错误2:configure: error: xml2-config not found. Please check your libxml2 installation.

解决:libxml2已经安装,还报这个错误,还需要安装libxml2-devel

错误3:error: Please reinstall the BZip2 distribution

解决:yum -y install bzip2-devel

错误4:checking for cURL in default path... not found

解决:yum -y install curl-devel

5:configure: error: jpeglib.h not found.

:yum -y install libjpeg-devel

6:configure: error: png.h not found.

:yum -y install libpng-devel

7:Configure: error: freetype.h not found.

:yum install freetype-devel

8:configure: error: Unable to locate gmp.h

:yum -y install gmp-devel

9:configure: error: mcrypt.h not found. Please reinstall libmcrypt.

:wget https://nchc.dl.sourceforge.net/project/mcrypt/Libmcrypt/2.5.8/libmcrypt-2.5.8.tar.gz

tar zxflibmcrypt-2.5.8.tar.gz

cdlibmcrypt-2.5.8

./configure

make && make install

10:configure: error: Don‘t know how to define struct flock on this system, set --enable-opcache=no

:编辑 /etc/ld.so.conf 加入/usr/local/lib,在执行ldconfig。

这个比较麻烦,参考http://www.68idc.cn/help/jiabenmake/qita/2014022169481.html

11:configure: error: Please reinstall readline - I cannot find readline.h

:yum -y install readline-devel

12:configure: error: xslt-config not found. Please reinstall the libxslt >= 1.1.0 distribution

:yum -y install libxslt-devel

13.configure: error: Please reinstall the libcurl distribution -
easy.h should be in /include/curl/

    安装curl-devel

14、mcrypt.h not found. Please reinstall libmcrypt
    libmcrypt-2.5.8

    15、Don‘t know how to define struct flock on this system, set --enable-opcache=no
    vim /etc/ld.so.conf.d/local.conf(vi etc/ld.so.conf)     # 编辑库文件(该文件可能不存在,不存在则创建一个新的)

/usr/local/lib # 添加该行
/usr/local/lib64 # 64位系统的除了添加上一行,还需要添加此行
:wq # 保存退出
ldconfig -v # 使之生效

16、Please reinstall readline - I cannot find readline.h
安装readline-devel

17、WARNING: unrecognized options: --enable-bz2
            删了--enable-bz2

centos7安装php5.6报错集合

原文:http://blog.51cto.com/13757802/2132666

人吐槽 人点赞

猜你喜欢

发表评论

用户名: 密码:
验证码: 匿名发表

你可以使用这些语言

查看评论:centos7安装php5.6报错集合