多版本PHP部署及composer配置

mac

#安装php5.6
brew install php56
#安装php7.1
brew install php71
#安装composer
brew install composer

此时composer对应的php版本是5.6

现在我们有一个项目A是php5.6的,有一个项目B是php7.1的

访问项目A要求用的是php5.6版本,访问项目B时要求用的是php7.1

#方案一
#查看当前php版本
php -v
#假设结果是5.6
#访问项目B的时候
brew unlink php56
brew link php71
brew services start php71
#此时再查看php版本已切换至php7.1
php -v
#如果要切回php5.6
brew unlink php71
brew link php56
brew services start php56

此时用phpstorm打开两个项目

在项目A中执行composer命令是正常的


文章来源: 多版本PHP部署及composer配置

人吐槽 人点赞

猜你喜欢

发表评论

用户名: 密码:
验证码: 匿名发表

你可以使用这些语言

查看评论:多版本PHP部署及composer配置