Wamp apache2.4.9升级php5.5.12到5.6中问题汇总

今天突然想研究下ThinkPHP5.0,结果发现要求php5.6以上,没办法,只好升级下php版本了,因为一直使用的是wampserver,参考网上的文章,整理一下,具体步骤如下:

特别注意:因为安装的wampserver是32位的,所以下面的扩展下载的时候都要求32位的,否则php版本切换的时候会失败,血的教训!!!

1、php官网下载对应版本的php安装包(下载页面:http://windows.php.net/download#php-5.6,我现在的5.6.36版本);

2、在wamp/bin/php目录新建php5.6.36目录(与php5.5.12同级),将第一步下载的zip文件解压到此目录下;

3、复制php5.5.12下的php.ini、php-cli.php、phpForApache.ini、wampserver.conf至php5.6.36目录下,并将php.ini、php-cli.php、phpForApache.ini中的5.5.12全部替换成5.6.36;

(注意:因为平常有时候会使用到cli模式,所有php-cli.ini配置也一起改了,同时注意环境变量的路径也要改到php5.6.36目录)

4、因为php升级了,所以xdebug版本也要相应修改,所以打开链接https://xdebug.org/download.php下载匹配版本的xdebug扩展,我这里选择的是PHP 5.6 VC11 TS (32bit),如果不是升级到5.6版本,版本自选;

5、在5.6.36文件夹下新建文件夹,命名为zend_ext,并将上一步下载的dll文件复制到zend_ext下;

6、将php.ini、php-cli.php、phpForApache.ini中的“php_xdebug-2.2.5-5.5-vc11.dll”扩展替换为“php_xdebug-2.5.4-5.6-vc11.dll”。

到这里,php的升级其实已经结束了,cmd模式下,输入“php -v”已经可以看到php的版本显示为5.6.36(如果有WARN警告请看问题汇总,没有可以重启服务器了)。

重启wampserver,左键单击右下角图标,PHP=》Version,如果没有报错的话,应该会显示两个版本号,即5.5.12和5.6.36,如果没有5.6.36,不要害怕,点击一下一下5.5.12,等待服务重启,然后就会发现有两个版本号了,点击版本号,就可以切换wampserver的php版本了。


问题汇总(扩展升级):

1.curl

php5.6中curl扩展默认是打开的,也就是说,你不需要再去php.ini中找到“;extension=php_curl.dll”去掉前面的分号了,如果再这里遇到问题说curl扩展没有加载的话,解决办法:将php5.6.36目录下的libssh2.dll复制到apache的bin目录,并重新启动apache;

2.sqlserver

因为我的项目操作的数据比较多,有些数据存放在sqlserver中,php5.5的时候已经安装了pdo-sqlsrv扩展,这时候,扩展也要跟着php升级。

首先,在微软官网https://www.microsoft.com/en-us/download/details.aspx?id=20098下载sqlserver的php驱动:Download=》SQLSRV32.EXE,然后随便新建一个目录,打开exe文件,选择新建的文件夹为解压目录,确定。

解压完成,复制其中的php_pdo_sqlsrv_56_ts.dll和php_sqlsrv_56_ts.dll(版本匹配,线程安全)两个文件复制到php5.6.36\ext文件夹下,然后修改上面三个配置文件中的扩展,将“extension=php_pdo_sqlsrv_55_ts.dll extension=php_sqlsrv_55_ts.dll”中的55全改成56(因为我之前安装过)。

3.mongodb

同sqlserver,在网站https://windows.php.net/downloads/pecl/releases/mongo/下载到MongoDB对应的版本的驱动,注意带php5.6-vc11-ts几个关键字的,然后复制到ext文件下。



文章来源: Wamp apache2.4.9升级php5.5.12到5.6中问题汇总

人吐槽 人点赞

猜你喜欢

发表评论

用户名: 密码:
验证码: 匿名发表

你可以使用这些语言

查看评论:Wamp apache2.4.9升级php5.5.12到5.6中问题汇总